London Data Center Degraded Performance
Incident Report for Perimeter 81
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 18:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2024 - 17:45 UTC
Investigating
We are currently investigating this issue.
Posted Apr 25, 2024 - 17:09 UTC
This incident affected: EMEA Regions (London 1).